TLS 1.0 or TLS 1.1 error message

Problem statement

When you try to make a payment, or to create a subscription plan the plugin displays the following error message:

Stripe no longer supports API requests made with TLS 1.0. Please initiate HTTPS connections with TLS 1.2 or later. You can learn more about this at https://stripe.com/blog/upgrading-tls.

This usually means that the OpenSSL package on your webserver is out of date.

The solution

Please update OpenSSL on your webserver to support TLS 1.2 .

You can find more information about the upgrade on this Stripe page:
https://support.stripe.com/questions/how-do-i-upgrade-my-openssl-to-support-tls-1-2

in Troubleshooting