This article is for an older version of the plugin
If you're looking for the latest version of the documentation, click here

TLS 1.0 or TLS 1.1 error message

You cannot use the plugin because a stange error message is displayed when making a payment.

What happened?

When a customer tries to make a payment the plugin displays the following error message:

Stripe no longer supports API requests made with TLS 1.0. Please initiate HTTPS connections with TLS 1.2 or later. You can learn more about this at https://stripe.com/blog/upgrading-tls.

Why is it happening?

Stripe stopped supporting TLS v1.0 on May 1, 2017. TLS is a cryptographic protocol which was phased out in favor of TLS v1.2 .

What is the solution?

Please update OpenSSL on your webserver to support TLS 1.2 .

You can find more information about the upgrade on this Stripe page:
https://support.stripe.com/questions/how-do-i-upgrade-my-openssl-to-support-tls-1-2

Still not finding the solution?

Our support team is happy to help you.

Contact support

Feature requests are always welcome!
We consider each feature request carefully, and examine how it fits the roadmap for the plugin.